CVE-2007-2172

2007-04-22T15:19:00
ID CVE-2007-2172
Type cve
Reporter NVD
Modified 2017-10-10T21:32:07

Description

A typo in Linux kernel 2.6 before 2.6.21-rc6 and 2.4 before 2.4.35 causes RTA_MAX to be used as an array size instead of RTN_MAX, which leads to an "out of bound access" by the (1) dn_fib_props (dn_fib.c, DECNet) and (2) fib_props (fib_semantics.c, IPv4) functions.