CVE-2006-2916

2006-06-15T10:02:00
ID CVE-2006-2916
Type cve
Reporter cve@mitre.org
Modified 2018-10-18T16:43:00

Description

artswrapper in aRts, when running setuid root on Linux 2.6.0 or later versions, does not check the return value of the setuid function call, which allows local users to gain root privileges by causing setuid to fail, which prevents artsd from dropping privileges. Product is only vulnerable when running setuid root on Linux 2.6.0 or later versions. Vendor links provide patches for each affected version.