CVE-2006-2898

2006-06-07T10:02:00
ID CVE-2006-2898
Type cve
Reporter cve@mitre.org
Modified 2018-10-18T16:43:00

Description

The IAX2 channel driver (chan_iax2) for Asterisk 1.2.x before 1.2.9 and 1.0.x before 1.0.11 allows remote attackers to cause a denial of service (crash) and execute arbitrary code via truncated IAX 2 (IAX2) video frames, which bypasses a length check and leads to a buffer overflow involving negative length check. NOTE: the vendor advisory claims that only a DoS is possible, but the original researcher is reliable. This vulnerability is addressed in the following product releases: Asterisk, Asterisk, 1.2.9 Asterisk, Asterisk, 1.0.11