logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2005-2233

Description

Buffer overflow in multiple "p" commands in IBM AIX 5.1, 5.2 and 5.3 might allow local users to execute arbitrary code via long command line arguments to (1) penable or other hard-linked files including (2) pdisable, (3) pstart, (4) phold, (5) pdelay, or (6) pshare.


Affected Software


CPE Name Name Version
ibm:aix ibm aix 5.1
ibm:aix ibm aix 5.3
ibm:aix ibm aix 5.1l
ibm:aix ibm aix 5.2
ibm:aix ibm aix 5.2.2
ibm:aix ibm aix 5.2_l
ibm:aix ibm aix 5.3_l