CVE-2005-2072

2005-06-29T04:00:00
ID CVE-2005-2072
Type cve
Reporter cve@mitre.org
Modified 2018-10-30T16:25:00

Description

The runtime linker (ld.so) in Solaris 8, 9, and 10 trusts the LD_AUDIT environment variable in setuid or setgid programs, which allows local users to gain privileges by (1) modifying LD_AUDIT to reference malicious code and possibly (2) using a long value for LD_AUDIT.