logo
DATABASE RESOURCES PRICING ABOUT US

Apache Pulsar Trust Management Issue Vulnerability

Description

Apache Pulsar is an Apache Foundation distributed messaging platform for cloud environments that integrates messaging, storage, and lightweight functional computing. The software supports multi-tenancy, persistent storage, multi-room cross-regional data replication, and highly scalable streaming data storage with strong consistency, high throughput, and low latency. The vulnerability is caused by Apache Pulsar Brokers and Proxies creating an internal Pulsar Admin Client that does not validate peer-to-peer TLS certificates, even if tlsAllowInsecureConnection is disabled through configuration, which could be exploited by an attacker to implement a man-in-the-middle attack through the Proxy Admin client.


Affected Software


CPE Name Name Version
apache pulsar 2.7.5
apache pulsar >=2.8.0, 2.8.4
apache pulsar >=2.9.0, 2.9.3
apache pulsar 2.10.0

Related