logo
DATABASE RESOURCES PRICING ABOUT US

libsolv Heap Overflow Vulnerability (CNVD-2022-15951)

Description

libsolv is a library for checking package dependencies. libsolv is vulnerable to a heap overflow vulnerability, which stems from the existence of two memory vulnerabilities in libsolv located in the resolve_weak function in src/solver.c. No detailed vulnerability details are currently available.


Affected Software


CPE Name Name Version
opensuse libsolv 0.6.4
opensuse libsolv 0.6.5
opensuse libsolv 0.6.6
opensuse libsolv 0.6.7
opensuse libsolv 0.6.8
opensuse libsolv 0.6.9
opensuse libsolv 0.6.10
opensuse libsolv 0.6.11
opensuse libsolv 0.6.12
opensuse libsolv 0.6.13

Related