logo
DATABASE RESOURCES PRICING ABOUT US

USN-4058-1: Bash vulnerability | Cloud Foundry

Description

# ## Severity Low ## Vendor Canonical Ubuntu ## Versions Affected * Canonical Ubuntu 16.04 ## Description It was discovered that Bash incorrectly handled the restricted shell. An attacker could possibly use this issue to escape restrictions and execute any command. CVEs contained in this USN include: CVE-2019-9924 ## Affected Cloud Foundry Products and Versions _Severity is low unless otherwise noted._ * Cloud Foundry BOSH xenial-stemcells are vulnerable, including: * 315.x versions prior to 315.72 * 250.x versions prior to 250.84 * 170.x versions prior to 170.111 * 97.x versions prior to 97.135 * All other stemcells not listed. ## Mitigation Users of affected products are strongly encouraged to follow one of the mitigations below: * The Cloud Foundry project recommends upgrading the following BOSH xenial-stemcells: * Upgrade 315.x versions to 315.72 * Upgrade 250.x versions to 250.84 * Upgrade 170.x versions to 170.111 * Upgrade 97.x versions to 97.135 * All other stemcells should be upgraded to the latest version available on [bosh.io](<https://bosh.io/stemcells/#ubuntu-xenial>). ## References * [USN-4058-1](<https://usn.ubuntu.com/4058-1>) * [CVE-2019-9924](<https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9924>)


Related