Lucene search

K
cloudfoundryCloud FoundryCFOUNDRY:E588E7E98F63E408541A6FF7CEE83CD2
HistoryMar 18, 2024 - 12:00 a.m.

USN-6505-1: nghttp2 vulnerability | Cloud Foundry

2024-03-1800:00:00
Cloud Foundry
www.cloudfoundry.org
24
nghttp2
canonical ubuntu
cloud foundry
denial of service
vulnerability
cve-2023-44487
update instructions
mitigation
resource consumption
usn-6505-1

CVSS3

7.5

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

AI Score

7.3

Confidence

High

EPSS

0.708

Percentile

98.1%

Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 22.04

Description

It was discovered that nghttp2 incorrectly handled request cancellation. A remote attacker could possibly use this issue to cause nghttp2 to consume resources, leading to a denial of service. Update Instructions: Run sudo pro fix USN-6505-1 to fix the vulnerability. The problem can be corrected by updating your system to the following package versions: libnghttp2-14 – 1.40.0-1ubuntu0.2 libnghttp2-doc – 1.40.0-1ubuntu0.2 libnghttp2-dev – 1.40.0-1ubuntu0.2 nghttp2-proxy – 1.40.0-1ubuntu0.2 nghttp2 – 1.40.0-1ubuntu0.2 nghttp2-client – 1.40.0-1ubuntu0.2 nghttp2-server – 1.40.0-1ubuntu0.2 No subscription required

CVEs contained in this USN include: CVE-2023-44487.

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • cflinuxfs4
    • All versions prior to 1.52.0
  • Jammy Stemcells
    • 1.x versions prior to 1.309
    • All other stemcells not listed.
  • CF Deployment
    • All versions with Jammy Stemcells prior to 1.309

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below.

The Cloud Foundry project recommends upgrading the following releases:

  • cflinuxfs4
    • Upgrade all versions to 1.52.0 or greater
  • Jammy Stemcells
    • Upgrade 1.x versions to 1.309 or greater
    • All other stemcells should be upgraded to the latest version available on bosh.io.
  • CF Deployment
    • For all versions, upgrade Jammy Stemcells to 1.309 or greater

References

History

2024-03-18: Initial vulnerability report published.

Affected configurations

Vulners
Node
cloudfoundrygorouterRange<1.52.0
OR
cloudfoundrygorouterRange<1.309
OR
cloudfoundrycf-deploymentRange<1.309

CVSS3

7.5

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

AI Score

7.3

Confidence

High

EPSS

0.708

Percentile

98.1%