Lucene search

K
cloudfoundryCloud FoundryCFOUNDRY:AE1E6DE27B0129A3E7944F2FE49C5406
HistoryMar 11, 2022 - 12:00 a.m.

USN-5240-1: Linux kernel vulnerability | Cloud Foundry

2022-03-1100:00:00
Cloud Foundry
www.cloudfoundry.org
34

0.001 Low

EPSS

Percentile

25.6%

Severity

High

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 18.04

Description

William Liu and Jamie Hill-Daniel discovered that the file system context functionality in the Linux kernel contained an integer underflow vulnerability, leading to an out-of-bounds write. A local attacker could use this to cause a denial of service (system crash) or execute arbitrary code.

CVEs contained in this USN include: CVE-2022-0185.

Affected Cloud Foundry Products and Versions

Severity is high unless otherwise noted.

  • Bionic Stemcells
    • 1.x versions prior to 1.59
    • All other stemcells not listed.

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • Bionic Stemcells
    • Upgrade 1.x versions to 1.59 or greater
    • All other stemcells should be upgraded to the latest version available on bosh.io.

References

History

2022-03-11: Initial vulnerability report published.

CPENameOperatorVersion
bionic stemcellslt1.59