Lucene search

K
cloudfoundryCloud FoundryCFOUNDRY:8E671DB66CC777A32FC96E6B964ACEAC
HistoryApr 14, 2021 - 12:00 a.m.

USN-4890-1: Linux kernel vulnerabilities | Cloud Foundry

2021-04-1400:00:00
Cloud Foundry
www.cloudfoundry.org
36

EPSS

0.001

Percentile

17.2%

Severity

High

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 16.04

Description

Piotr Krysiuk discovered that the BPF subsystem in the Linux kernel did not properly compute a speculative execution limit on pointer arithmetic in some situations. A local attacker could use this to expose sensitive information (kernel memory). (CVE-2020-27171)

Piotr Krysiuk discovered that the BPF subsystem in the Linux kernel did not properly apply speculative execution limits on some pointer types. A local attacker could use this to expose sensitive information (kernel memory). (CVE-2020-27170)

CVEs contained in this USN include: CVE-2020-27170, CVE-2020-27171.

Affected Cloud Foundry Products and Versions

Severity is high unless otherwise noted.

  • Xenial Stemcells
    • 456.x versions prior to 456.154
    • 621.x versions prior to 621.117
    • All other stemcells not listed.

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • Xenial Stemcells
    • Upgrade 456.x versions to 456.154 or greater
    • Upgrade 621.x versions to 621.117 or greater
    • All other stemcells should be upgraded to the latest version available on bosh.io.

References

History

2021-04-14: Initial vulnerability report published.