Lucene search

K
cloudfoundryCloud FoundryCFOUNDRY:59646A5BD0704F764C59082E10E2C19A
HistoryFeb 03, 2023 - 12:00 a.m.

USN-5823-1: MySQL vulnerabilities | Cloud Foundry

2023-02-0300:00:00
Cloud Foundry
www.cloudfoundry.org
27

9.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

0.007 Low

EPSS

Percentile

79.8%

Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 18.04

Description

Multiple security issues were discovered in MySQL and this update includes new upstream MySQL versions to fix these issues. MySQL has been updated to 8.0.32 in Ubuntu 20.04 LTS, Ubuntu 22.04 LTS, and Ubuntu 22.10. Ubuntu 18.04 LTS has been updated to MySQL 5.7.41. In addition to security fixes, the updated packages contain bug fixes, new features, and possibly incompatible changes. Please see the following for more information: https://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-41.html https://dev.mysql.com/doc/relnotes/mysql/8.0/en/news-8-0-32.html https://www.oracle.com/security-alerts/cpujan2023.html Update Instructions: Run sudo pro fix USN-5823-1 to fix the vulnerability. The problem can be corrected by updating your system to the following package versions: mysql-client – 5.7.41-0ubuntu0.18.04.1 mysql-source-5.7 – 5.7.41-0ubuntu0.18.04.1 libmysqlclient-dev – 5.7.41-0ubuntu0.18.04.1 mysql-client-core-5.7 – 5.7.41-0ubuntu0.18.04.1 mysql-client-5.7 – 5.7.41-0ubuntu0.18.04.1 libmysqlclient20 – 5.7.41-0ubuntu0.18.04.1 mysql-server-5.7 – 5.7.41-0ubuntu0.18.04.1 mysql-server – 5.7.41-0ubuntu0.18.04.1 mysql-server-core-5.7 – 5.7.41-0ubuntu0.18.04.1 mysql-testsuite – 5.7.41-0ubuntu0.18.04.1 libmysqld-dev – 5.7.41-0ubuntu0.18.04.1 mysql-testsuite-5.7 – 5.7.41-0ubuntu0.18.04.1 No subscription required

CVEs contained in this USN include: CVE-2022-32221, CVE-2023-21836, CVE-2023-21840, CVE-2023-21863, CVE-2023-21867, CVE-2023-21868, CVE-2023-21869, CVE-2023-21870, CVE-2023-21871, CVE-2023-21873, CVE-2023-21875, CVE-2023-21876, CVE-2023-21877, CVE-2023-21878, CVE-2023-21879, CVE-2023-21880, CVE-2023-21881, CVE-2023-21882, CVE-2023-21883, CVE-2023-21887.

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • cflinuxfs3
    • All versions prior to 0.8.0
  • CF Deployment
    • All versions prior to 1.9.0

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • cflinuxfs3
    • Upgrade all versions to 0.8.0 or greater
  • CF Deployment
    • Upgrade all versions to 1.9.0 or greater

References

History

2023-02-03: Initial vulnerability report published.

Affected configurations

Vulners
Node
cloud_foundrydiegoRange<0.8.0
OR
cloud_foundrycf-networkingRange<1.9.0
CPENameOperatorVersion
cflinuxfs3lt0.8.0
cf deploymentlt1.9.0

9.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

0.007 Low

EPSS

Percentile

79.8%