USN-3385-2: Linux kernel (Xenial HWE) vulnerabilities | Cloud Foundry

2017-08-17T00:00:00
ID CFOUNDRY:55CD35F3011A699D7E30AD5252951E34
Type cloudfoundry
Reporter Cloud Foundry
Modified 2017-08-17T00:00:00

Description

Severity

High

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 14.04

Description

USN-3385-1 fixed vulnerabilities in the Linux kernel for Ubuntu 16.04 LTS. This update provides the corresponding updates for the Linux Hardware Enablement (HWE) kernel from Ubuntu 16.04 LTS for Ubuntu 14.04 LTS.

Andrey Konovalov discovered a race condition in the UDP Fragmentation Offload (UFO) code in the Linux kernel. A local attacker could use this to cause a denial of service or execute arbitrary code. (CVE-2017-1000112)

Andrey Konovalov discovered a race condition in AF_PACKET socket option handling code in the Linux kernel. A local unprivileged attacker could use this to cause a denial of service or possibly execute arbitrary code. (CVE-2017-1000111)

Affected Cloud Foundry Products and Versions

Severity is high unless otherwise noted.

  • Cloud Foundry BOSH stemcells are vulnerable, including:
    • 3312.x versions prior to 3312.33
    • 3363.x versions prior to 3363.3
    • 3421.x versions prior to 3421.19
    • All other stemcells not listed.

Mitigation

OSS users are strongly encouraged to follow one of the mitigations below:

  • The Cloud Foundry project recommends upgrading the following BOSH stemcells:
    • Upgrade 3312.x versions prior to 3312.33
    • Upgrade 3363.x versions prior to 3363.3
    • Upgrade 3421.x versions prior to 3421.19
    • All other stemcells should be upgraded to the latest version available on bosh.io.

References