logo
DATABASE RESOURCES PRICING ABOUT US

USN-3294-1: Bash vulnerabilities | Cloud Foundry

Description

# # Severity Medium # Vendor Canonical Ubuntu # Versions Affected * Canonical Ubuntu 14.04 # Description Bernd Dietzel discovered that Bash incorrectly expanded the hostname when displaying the prompt. If a remote attacker were able to modify a hostname, this flaw could be exploited to execute arbitrary code. This issue only affected Ubuntu 14.04 LTS, Ubuntu 16.04 LTS and Ubuntu 16.10. ([CVE-2016-0634](<http://people.ubuntu.com/~ubuntu-security/cve/CVE-2016-0634>)) It was discovered that Bash incorrectly handled the SHELLOPTS and PS4 environment variables. A local attacker could use this issue to execute arbitrary code with root privileges. This issue only affected Ubuntu 14.04 LTS, Ubuntu 16.04 LTS and Ubuntu 16.10. ([CVE-2016-7543](<http://people.ubuntu.com/~ubuntu-security/cve/CVE-2016-7543>)) It was discovered that Bash incorrectly handled the popd command. A remote attacker could possibly use this issue to bypass restricted shells. ([CVE-2016-9401](<http://people.ubuntu.com/~ubuntu-security/cve/CVE-2016-9401>)) It was discovered that Bash incorrectly handled path autocompletion. A local attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 17.04. ([CVE-2017-5932](<http://people.ubuntu.com/~ubuntu-security/cve/CVE-2017-5932>)) # Affected Cloud Foundry Products and Versions _Severity is medium unless otherwise noted._ * Cloud Foundry BOSH stemcells are vulnerable, including: * 3263.x versions prior to 3263.26 * 3312.x versions prior to 3312.26 * 3363.x versions prior to 3363.24 * All other stemcells not listed. * All versions of Cloud Foundry cflinuxfs2 prior to 1.122.0 # Mitigation OSS users are strongly encouraged to follow one of the mitigations below: * The Cloud Foundry project recommends upgrading the following BOSH stemcells: * Upgrade 3263.x versions to 3263.26 or later * Upgrade 3312.x versions to 3312.26 or later * Upgrade 3363.x versions to 3363.24 or later * All other stemcells should be upgraded to the latest version. * The Cloud Foundry project recommends that Cloud Foundry deployments run with cflinuxfs2 version 1.122.0 or later. # References * [USN-3294-1](<http://www.ubuntu.com/usn/usn-3294-1/>) * [CVE-2016-0634](<http://people.ubuntu.com/~ubuntu-security/cve/CVE-2016-0634>) * [CVE-2016-7543](<http://people.ubuntu.com/~ubuntu-security/cve/CVE-2016-7543>) * [CVE-2016-9401](<http://people.ubuntu.com/~ubuntu-security/cve/CVE-2016-9401>) * [CVE-2017-5932](<http://people.ubuntu.com/~ubuntu-security/cve/CVE-2017-5932>) * [bosh.io](<https://bosh.io>)


Related