Lucene search

K
cloudfoundryCloud FoundryCFOUNDRY:47217BCBAA274835470BD1E2FB8551A6
HistoryDec 18, 2019 - 12:00 a.m.

USN-4220-1: Git vulnerabilities | Cloud Foundry

2019-12-1800:00:00
Cloud Foundry
www.cloudfoundry.org
18

EPSS

0.087

Percentile

94.6%

Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 18.04

Description

Joern Schneeweisz and Nicolas Joly discovered that Git contained various security flaws. An attacker could possibly use these issues to overwrite arbitrary paths, execute arbitrary code, and overwrite files in the .git directory.

CVEs contained in this USN include: CVE-2019-1348, CVE-2019-1349, CVE-2019-1350, CVE-2019-1351, CVE-2019-1352, CVE-2019-1353, CVE-2019-1354, CVE-2019-1387, CVE-2019-19604

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • All versions of Cloud Foundry cflinuxfs3 prior to 0.151.0

Mitigation

Users of affected products are strongly encouraged to follow one of the mitigations below:

  • The Cloud Foundry project recommends that Cloud Foundry deployments run with cflinuxfs3 version 0.151.0 or later.

References