logo
DATABASE RESOURCES PRICING ABOUT US

USN-3879-2: Linux kernel (Xenial HWE) vulnerabilities | Cloud Foundry

Description

# # Severity Medium # Vendor Canonical Ubuntu # Versions Affected * Canonical Ubuntu 14.04 # Description USN-3879-1 fixed vulnerabilities in the Linux kernel for Ubuntu 16.04 LTS. This update provides the corresponding updates for the Linux Hardware Enablement (HWE) kernel from Ubuntu 16.04 LTS for Ubuntu 14.04 LTS. Wen Xu discovered that the ext4 file system implementation in the Linux kernel could possibly perform an out of bounds write when updating the journal for an inline file. An attacker could use this to construct a malicious ext4 image that, when mounted, could cause a denial of service (system crash). (CVE-2018-10883) Vasily Averin and Pavel Tikhomirov discovered that the cleancache subsystem of the Linux kernel did not properly initialize new files in some situations. A local attacker could use this to expose sensitive information. (CVE-2018-16862) Wei Wu discovered that the KVM implementation in the Linux kernel did not properly ensure that ioapics were initialized. A local attacker could use this to cause a denial of service (system crash). (CVE-2018-19407) Mathias Payer and Hui Peng discovered a use-after-free vulnerability in the Advanced Linux Sound Architecture (ALSA) subsystem. A physically proximate attacker could use this to cause a denial of service (system crash). (CVE-2018-19824) Hui Peng and Mathias Payer discovered that the USB subsystem in the Linux kernel did not properly handle size checks when handling an extra USB descriptor. A physically proximate attacker could use this to cause a denial of service (system crash). (CVE-2018-20169) CVEs contained in this USN include: CVE-2018-10883, CVE-2018-19407, CVE-2018-16862, CVE-2018-19824, CVE-2018-20169 # Affected Cloud Foundry Products and Versions _Severity is medium unless otherwise noted._ * Cloud Foundry BOSH trusty-stemcells are vulnerable, including: * 3586.x versions prior to 3586.79 * 3541.x versions prior to 3541.80 * 3468.x versions prior to 3468.101 * 3445.x versions prior to 3445.97 * 3421.x versions prior to 3421.117 * All other stemcells not listed. # Mitigation Users of affected products are strongly encouraged to follow one of the mitigations below: * The Cloud Foundry project recommends upgrading the following BOSH trusty-stemcells: * Upgrade 3586.x versions to 3586.79 * Upgrade 3541.x versions to 3541.80 * Upgrade 3468.x versions to 3468.101 * Upgrade 3445.x versions to 3445.97 * Upgrade 3421.x versions to 3421.117 * All other stemcells should be upgraded to the latest version available on [bosh.io](<https://bosh.io/stemcells/#ubuntu-trusty>). # References * [USN-3879-2](<https://usn.ubuntu.com/3879-2>) * [CVE-2018-10883](<https://people.canonical.com/~ubuntu-security/cve/CVE-2018-10883>) * [CVE-2018-19407](<https://people.canonical.com/~ubuntu-security/cve/CVE-2018-19407>) * [CVE-2018-16862](<https://people.canonical.com/~ubuntu-security/cve/CVE-2018-16862>) * [CVE-2018-19824](<https://people.canonical.com/~ubuntu-security/cve/CVE-2018-19824>) * [CVE-2018-20169](<https://people.canonical.com/~ubuntu-security/cve/CVE-2018-20169>)


Related