Lucene search

K
cloudfoundryCloud FoundryCFOUNDRY:14960AA0EEBC4A5CC57652EBAC248E97
HistoryAug 16, 2023 - 12:00 a.m.

USN-6195-1: Vim vulnerabilities | Cloud Foundry

2023-08-1600:00:00
Cloud Foundry
www.cloudfoundry.org
21
vim
canonical ubuntu
vulnerabilities
denial of service
arbitrary code execution
mitigation

CVSS2

6.8

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS3

7.8

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

EPSS

0.001

Percentile

51.1%

Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 22.04

Description

It was discovered that Vim contained an out-of-bounds read vulnerability. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2022-0128) It was discovered that Vim did not properly manage memory when freeing allocated memory. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2022-0156) It was discovered that Vim contained a heap-based buffer overflow vulnerability. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2022-0158) It was discovered that Vim did not properly manage memory when recording and using select mode. An attacker could possibly use this issue to cause a denial of service. (CVE-2022-0393) It was discovered that Vim incorrectly handled certain memory operations during a visual block yank. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2022-0407) It was discovered that Vim contained a NULL pointer dereference vulnerability when switching tabpages. An attacker could possible use this issue to cause a denial of service. (CVE-2022-0696) Update Instructions: Run sudo pro fix USN-6195-1 to fix the vulnerability. The problem can be corrected by updating your system to the following package versions: vim-common – 2:8.2.3995-1ubuntu2.9 vim-athena – 2:8.2.3995-1ubuntu2.9 vim-tiny – 2:8.2.3995-1ubuntu2.9 vim-gtk – 2:8.2.3995-1ubuntu2.9 vim-gui-common – 2:8.2.3995-1ubuntu2.9 vim – 2:8.2.3995-1ubuntu2.9 vim-doc – 2:8.2.3995-1ubuntu2.9 xxd – 2:8.2.3995-1ubuntu2.9 vim-runtime – 2:8.2.3995-1ubuntu2.9 vim-gtk3 – 2:8.2.3995-1ubuntu2.9 vim-nox – 2:8.2.3995-1ubuntu2.9 No subscription required

CVEs contained in this USN include: CVE-2022-0128, CVE-2022-0156, CVE-2022-0158, CVE-2022-0393, CVE-2022-0407, CVE-2022-0696.

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • cflinuxfs4
    • All versions prior to 1.22.0
  • Jammy Stemcells
    • 1.x versions prior to 1.179
    • All other stemcells not listed.
  • CF Deployment
    • All versions with Jammy Stemcells prior to 1.179

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • cflinuxfs4
    • Upgrade all versions to 1.22.0 or greater
  • Jammy Stemcells
    • Upgrade 1.x versions to 1.179 or greater
    • All other stemcells should be upgraded to the latest version available on bosh.io.
  • CF Deployment
    • For all versions, upgrade Jammy Stemcells to 1.179 or greater

References

History

2023-08-16: Initial vulnerability report published.

Affected configurations

Vulners
Node
cloudfoundrygorouterRange<1.22.0
OR
cloudfoundrygorouterRange<1.179
OR
cloudfoundrycf-deploymentRange<1.179

CVSS2

6.8

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS3

7.8

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

EPSS

0.001

Percentile

51.1%