Lucene search

K
cloudfoundryCloud FoundryCFOUNDRY:143DD0B723168984741426AB2A1F18AB
HistorySep 11, 2018 - 12:00 a.m.

USN-3732-2: Linux kernel (HWE) vulnerability | Cloud Foundry

2018-09-1100:00:00
Cloud Foundry
www.cloudfoundry.org
526

EPSS

0.783

Percentile

98.3%

Severity

High

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 16.04

Description

USN-3732-1 fixed vulnerabilities in the Linux kernel for Ubuntu 18.04 LTS. This update provides the corresponding updates for the Linux Hardware Enablement (HWE) kernel from Ubuntu 18.04 LTS for Ubuntu 16.04 LTS.

Juha-Matti Tilli discovered that the TCP implementation in the Linux kernel performed algorithmically expensive operations in some situations when handling incoming packets. A remote attacker could use this to cause a denial of service.

Affected Cloud Foundry Products and Versions

Severity is high unless otherwise noted.

  • Cloud Foundry BOSH xenial-stemcells are vulnerable, including:
    • 97.x versions prior to 97.12
    • All other stemcells not listed.

Mitigation

OSS users are strongly encouraged to follow one of the mitigations below:

  • The Cloud Foundry project recommends upgrading the following BOSH xenial-stemcells:
    • Upgrade 97.x versions to 97.12
    • All other stemcells should be upgraded to the latest version available on bosh.io.

References