Lucene search

K
cloudfoundryCloud FoundryCFOUNDRY:109AFB3218278B845293821BB7955147
HistoryApr 04, 2024 - 12:00 a.m.

USN-6541-1: GNU C Library vulnerabilities | Cloud Foundry

2024-04-0400:00:00
Cloud Foundry
www.cloudfoundry.org
10
gnu c library
memory handling
vulnerabilities
ubuntu 16.04
ubuntu 18.04
ubuntu 22.04
memory leak
denial of service
cve-2023-4806
cve-2023-4813
cve-2023-5156
cloud foundry
cflinuxfs4
jammy stemcells
cf deployment
mitigation
update instructions

7.5 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

9.5 High

AI Score

Confidence

High

0.001 Low

EPSS

Percentile

48.7%

Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04
  • Canonical Ubuntu 22.04

Description

It was discovered that the GNU C Library was not properly handling certain memory operations. An attacker could possibly use this issue to cause a denial of service (application crash). (CVE-2023-4806, CVE-2023-4813) It was discovered that the GNU C library was not properly implementing a fix for CVE-2023-4806 in certain cases, which could lead to a memory leak. An attacker could possibly use this issue to cause a denial of service (application crash). This issue only affected Ubuntu 22.04 LTS and Ubuntu 23.04. (CVE-2023-5156) Update Instructions: Run sudo pro fix USN-6541-1 to fix the vulnerability. The problem can be corrected by updating your system to the following package versions: libc-bin – 2.35-0ubuntu3.5 glibc-doc – 2.35-0ubuntu3.5 locales-all – 2.35-0ubuntu3.5 libc6-i386 – 2.35-0ubuntu3.5 libc6-s390 – 2.35-0ubuntu3.5 libc6-dev-i386 – 2.35-0ubuntu3.5 nscd – 2.35-0ubuntu3.5 libc6-dev-x32 – 2.35-0ubuntu3.5 libc6-dev – 2.35-0ubuntu3.5 libc6-amd64 – 2.35-0ubuntu3.5 libc6-x32 – 2.35-0ubuntu3.5 libc6-dev-amd64 – 2.35-0ubuntu3.5 libc-dev-bin – 2.35-0ubuntu3.5 libc6 – 2.35-0ubuntu3.5 libc6-prof – 2.35-0ubuntu3.5 libc-devtools – 2.35-0ubuntu3.5 glibc-source – 2.35-0ubuntu3.5 libc6-dev-s390 – 2.35-0ubuntu3.5 locales – 2.35-0ubuntu3.5 No subscription required

CVEs contained in this USN include: CVE-2023-4806, CVE-2023-4813, CVE-2023-5156.

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • cflinuxfs4
    • All versions prior to 1.58.0
  • Jammy Stemcells
    • 1.x versions prior to 1.327
    • All other stemcells not listed.
  • CF Deployment
    • All versions prior to 30.0.0, or later versions with Jammy Stemcells prior to 1.327

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below.

The Cloud Foundry project recommends upgrading the following releases:

  • cflinuxfs4
    • Upgrade all versions to 1.58.0 or greater
  • Jammy Stemcells
    • Upgrade 1.x versions to 1.327 or greater
    • All other stemcells should be upgraded to the latest version available on bosh.io.
  • CF Deployment
    • Upgrade all versions to 30.0.0 or greater and upgrade Jammy Stemcells to 1.327 or greater

References

History

2024-04-04: Initial vulnerability report published.

Affected configurations

Vulners
Node
cloudfoundrygorouterRange<1.58.0
OR
cloudfoundrygorouterRange<1.327
OR
cloudfoundrycf-deploymentRange<30.0.0

7.5 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

9.5 High

AI Score

Confidence

High

0.001 Low

EPSS

Percentile

48.7%