USN-4360-4: json-c vulnerability | Cloud Foundry

2020-06-24T00:00:00
ID CFOUNDRY:040F4CCCBFA0D40A833FE27260678A99
Type cloudfoundry
Reporter Cloud Foundry
Modified 2020-06-24T00:00:00

Description

Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 14.04
  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04

Description

USN-4360-1 fixed a vulnerability in json-c. The security fix introduced a memory leak that was reverted in USN-4360-2 and USN-4360-3. This update provides the correct fix update for CVE-2020-12762.

Original advisory details:

It was discovered that json-c incorrectly handled certain JSON files. An attacker could possibly use this issue to execute arbitrary code.

CVEs contained in this USN include: CVE-2020-12762.

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • cflinuxfs3
    • All versions prior to 0.189.0
  • Xenial Stemcells
    • 170.x versions prior to 170.221
    • 250.x versions prior to 250.200
    • 315.x versions prior to 315.185
    • 456.x versions prior to 456.114
    • 621.x versions prior to 621.76
    • All other stemcells not listed.
  • CF Deployment
    • All versions prior to v13.5.0

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • cflinuxfs3
    • Upgrade All versions to 0.189.0 or greater
  • Xenial Stemcells
    • Upgrade 170.x versions to 170.221 or greater
    • Upgrade 250.x versions to 250.200 or greater
    • Upgrade 315.x versions to 315.185 or greater
    • Upgrade 456.x versions to 456.114 or greater
    • Upgrade 621.x versions to 621.76 or greater
    • All other stemcells should be upgraded to the latest version available on bosh.io.
  • CF Deployment
    • Upgrade All versions to v13.5.0 or greater

References

History

2020-05-28: Initial vulnerability report published.