Cisco IOS XE Software Stored Cross-Site Scripting Vulnerability

2019-09-25T16:00:00
ID CISCO-SA-20190925-XSS
Type cisco
Reporter Cisco
Modified 2019-09-25T15:51:23

Description

A vulnerability in the web framework code of Cisco IOS XE Software could allow an authenticated, remote attacker to conduct a stored cross-site scripting (XSS) attack against a user of the web interface of the affected software.

The vulnerability is due to insufficient input validation of some parameters that are passed to the web server of the affected software. An attacker could exploit this vulnerability by convincing a user of the web interface to access a malicious link or by intercepting a user request for the affected web interface and injecting malicious code into the request. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected web interface or allow the attacker to access sensitive browser-based information.

Cisco has released software updates that address this vulnerability. There are no workarounds that address this vulnerability.

This advisory is available at the following link: https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190925-xss ["https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190925-xss"]