Cisco Elastic Services Controller Arbitrary Command Execution Vulnerability

2017-06-07T16:00:00
ID CISCO-SA-20170607-ESC1
Type cisco
Reporter Cisco
Modified 2017-06-06T16:32:43

Description

A vulnerability in the ConfD CLI of Cisco Elastic Services Controllers could allow an authenticated, remote attacker to run arbitrary commands as the Linux tomcat user on an affected system.

The vulnerability is due to insufficient sanitization of commands that are permitted to run from the ConfD CLI of an affected system. An attacker could exploit this vulnerability by breaking from the restricted shell of the ConfD CLI of an affected system and running arbitrary commands as the Linux tomcat user on the affected system.

There are no workarounds that address this vulnerability.

This advisory is available at the following link: https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20170607-esc1 ["https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20170607-esc1"]