Cisco Unified Web and E-mail Interaction Manager XML External Entities Vulnerability

2014-05-19T18:50:43
ID CISCO-SA-20140519-CVE-2014-2194
Type cisco
Reporter Cisco
Modified 2014-06-03T20:12:24

Description

A vulnerability in the /system/egain/chat/entrypoint script of Cisco Unified Web and E-mail Interaction Manager could allow an unauthenticated, remote attacker to inject malicious XML entities.

The vulnerability is due to inadequate input validation. An attacker could exploit this vulnerability by spoofing an XML external entity.

Cisco has confirmed the vulnerability in a security notice and software updates are available.

To exploit this vulnerability, an attacker must spoof an XML external entity on the targeted device. It is likely that the device would reside on trusted, internal networks that the attacker may need to access. This access requirement may reduce the likelihood of a successful exploit.

Cisco indicates through the CVSS score that functional exploit code exists; however, the code is not known to be publicly available.