pWhois Layer Four Traceroute 3.x vulnerability

2011-04-04T00:00:00
ID VU:946652
Type cert
Reporter CERT
Modified 2011-04-04T14:16:00

Description

Overview

Given a specific set of command line arguments, Layer Four Traceroute (lft) will produce a segmentation fault leading to a possible privilege escalation vulnerability.

Description

pWhois Layer Four Traceroute 3.x contains a vulnerability when parsing command line arguments. Earlier versions of Layer Four Traceroute may also be vulnerable. Some distributions that package Layer Four Traceroute are not vulnerable because they do not install the 'lft' binary SETUID root.


Impact

If Layer Four Traceroute is installed SETUID root, a local attacker may be able to exploit the vulnerability for privilege escalation.


Solution

Apply an Update

Upgrade to Layer Four Traceroute 3.3 or later.


Workaround

If upgrading to the latest version is not possible, do not install Layer Four Traceroute SETUID root. This will limit the application functionality for unprivileged users.


Vendor Information

946652

Filter by status: All Affected Not Affected Unknown

Filter by content: __ Additional information available

__ Sort by: Status Alphabetical

Expand all

Javascript is disabled. Click here to view vendors.

pwhois_lft Affected

Notified: January 19, 2011 Updated: April 04, 2011

Status

Affected

Vendor Statement

We have not received a statement from the vendor.

Vendor Information

We are not aware of further vendor information regarding this vulnerability.

Vendor References

  • <http://pwhois.org/lft/>

Red Hat, Inc. Not Affected

Notified: February 22, 2011 Updated: April 04, 2011

Status

Not Affected

Vendor Statement

We have not received a statement from the vendor.

Vendor Information

We are not aware of further vendor information regarding this vulnerability.

SUSE Linux Not Affected

Notified: February 22, 2011 Updated: April 04, 2011

Status

Not Affected

Vendor Statement

We have not received a statement from the vendor.

Vendor Information

We are not aware of further vendor information regarding this vulnerability.

Slackware Linux Inc. Not Affected

Notified: February 22, 2011 Updated: April 04, 2011

Status

Not Affected

Vendor Statement

We have not received a statement from the vendor.

Vendor Information

We are not aware of further vendor information regarding this vulnerability.

Ubuntu Not Affected

Notified: February 22, 2011 Updated: April 04, 2011

Status

Not Affected

Vendor Statement

We have not received a statement from the vendor.

Vendor Information

We are not aware of further vendor information regarding this vulnerability.

Debian GNU/Linux Unknown

Notified: February 22, 2011 Updated: February 22, 2011

Status

Unknown

Vendor Statement

We have not received a statement from the vendor.

Vendor Information

We are not aware of further vendor information regarding this vulnerability.

FreeBSD Project Unknown

Notified: February 22, 2011 Updated: February 22, 2011

Status

Unknown

Vendor Statement

We have not received a statement from the vendor.

Vendor Information

We are not aware of further vendor information regarding this vulnerability.

Gentoo Linux Unknown

Notified: February 22, 2011 Updated: February 22, 2011

Status

Unknown

Vendor Statement

We have not received a statement from the vendor.

Vendor Information

We are not aware of further vendor information regarding this vulnerability.

CVSS Metrics

Group | Score | Vector
---|---|---
Base | |
Temporal | |
Environmental | |

References

<http://pwhois.org/lft/>

Acknowledgements

Thanks to Markus Gothe for reporting this vulnerability.

This document was written by Jared Allar.

Other Information

CVE IDs: | CVE-2011-0765
---|---
Date Public: | 2011-04-04
Date First Published: | 2011-04-04
Date Last Updated: | 2011-04-04 14:16 UTC
Document Revision: | 18