WS_FTP Server vulnerable to buffer overflow when supplied overly long "APPE" command

2003-09-22T00:00:00
ID VU:792284
Type cert
Reporter CERT
Modified 2003-09-22T00:00:00

Description

Overview

It has been reported that a vulnerability exists in the processing of a "APPE" command on WS_FTP Servers versions 4.x and prior. Exploitation of this vulnerability may lead to an authenticated user executing arbitrary code with the elevated privileges of the server process.

Description

WS_FTP Server is a File Transfer Protocol server. A buffer overflow vulnerability has been reported in code that processes the "APPE" command (append). WS_FTP Servers versions 3.00, 4.00, 4.01 are vulnerable to this issue.


Impact

Access the server is required prior to exploitation of this vulnerability. Exploitation of this vulnerability may lead to an authenticated user executing arbitrary code with the elevated privileges of the server process. If the server is setup to permit anonymous access, then authentication is not a requirement for exploitation.


Solution

A patch was released for WS_FTP server 3.0 and is resolved in version 3.14.

<ftp://ftp.ipswitch.com/ipswitch/product_support/WS_FTP_Server/ifs314.exe>

A patch was released for WS_FTP server 4.00 and 4.01 and is resolved in version 4.02.

<ftp://ftp.ipswitch.com/ipswitch/product_support/ws_ftp_server/ifs402.exe>


Disable anonymous FTP access

Although disabling anonymous FTP access does not prevent attacks from occurring, it does prevent unauthenticated users from attempting to exploit the vulnerability.


Systems Affected

Vendor| Status| Date Notified| Date Updated
---|---|---|---
IPSWITCH| | -| 22 Sep 2003
If you are a vendor and your product is affected, let us know.

CVSS Metrics

Group | Score | Vector
---|---|---
Base | N/A | N/A
Temporal | N/A | N/A
Environmental | N/A | N/A

References

  • <http://www.secunia.com/advisories/9671/>

Credit

Thanks to Secunia Security Advisories for reporting this vulnerability.

This document was written by Jason A Rafail.

Other Information

  • CVE IDs: Unknown
  • Date Public: 04 Sep 2003
  • Date First Published: 22 Sep 2003
  • Date Last Updated: 22 Sep 2003
  • Severity Metric: 10.50
  • Document Revision: 8