Apache mod_jk2 host header buffer overflow

2008-02-14T00:00:00
ID VU:771937
Type cert
Reporter CERT
Modified 2008-04-29T00:00:00

Description

Overview

A vulnerability exists in the legacy version of the mod_jk2 Apache module. If successfully exploited, the vulnerability may allow an attacker to run arbitrary code on affected system.

Description

The host header field allows HTTP 1.1 (RFC 2616) compliant servers to host multiple domains using a single IP address.

Per the IOActive Security Advisory Multiple Buffer Overflows in legacy mod_jk2 apache module 2.0.3-DEV and earlier:

mod_jk2 versions less than 2.0.4 are vulnerable to multiple stack overflow vulnerabilities. Specifically, IOActive has discovered multiple
locations where these vulnerabilities are exploitable via the Host request header in any given request. These overflows all result in remote
code execution under the user of the running apache process. Although a legacy module which is end of life, certain vendors may use this
module in their products rendering them vulnerable to remote exploitation.


Impact

A remote, unauthenticated attacker may be able to execute arbitrary code.


Solution

Upgrade