Apache Portable Runtime contains heap buffer overflow in apr_psprintf()

2003-06-24T00:00:00
ID VU:757612
Type cert
Reporter CERT
Modified 2003-09-18T00:00:00

Description

Overview

The Apache HTTP server contains a denial-of-service vulnerability that allows remote attackers to conduct denial-of-service attacks against an affected server.

Description

The Apache HTTP server contains a heap buffer overflow vulnerability in the apr_psprintf() function. The Apache Software Foundation has provided the following description of this vulnerability:

Apache 2.0 versions 2.0.37 through 2.0.45 can be caused to crash in certain circumstances. This can be triggered remotely through mod_dav and possibly other mechanisms. The crash was originally reported by David Endler <DEndler@iDefense.com> and was researched and fixed by Joe Orton <jorton@redhat.com>. Specific details and an analysis of the crash will be published Friday, May 30. No more specific information is disclosed at this time, but all Apache 2.0 users are encouraged to upgrade now.

For further information, please read the announcement located at

<http://www.apache.org/dist/httpd/Announcement2.html>


Impact

This vulnerability allows remote attackers to conduct denial-of-service attacks against an affected server.


Solution

The Apache Software Foundation recommends that users upgrade to version 2.0.46 to address this vulnerability. The latest version of Apache is available at: