The Apache HTTP server contains a denial-of-service vulnerability that allows remote attackers to conduct denial-of-service attacks against an affected server.
The Apache HTTP server contains a heap buffer overflow vulnerability in the apr_psprintf() function. The Apache Software Foundation has provided the following description of this vulnerability:
Apache 2.0 versions 2.0.37 through 2.0.45 can be caused to crash in certain circumstances. This can be triggered remotely through mod_dav and possibly other mechanisms. The crash was originally reported by David Endler <DEndler@iDefense.com> and was researched and fixed by Joe Orton <firstname.lastname@example.org>. Specific details and an analysis of the crash will be published Friday, May 30. No more specific information is disclosed at this time, but all Apache 2.0 users are encouraged to upgrade now.
For further information, please read the announcement located at
This vulnerability allows remote attackers to conduct denial-of-service attacks against an affected server.
The Apache Software Foundation recommends that users upgrade to version 2.0.46 to address this vulnerability. The latest version of Apache is available at: