ManageEngine ServiceDesk directory traversal vulnerability

2011-06-27T00:00:00
ID VU:543310
Type cert
Reporter CERT
Modified 2011-06-27T00:00:00

Description

Overview

ManageEngine ServiceDesk contains a directory traversal vulnerability which may allow a remote, unauthenticated attacker to obtain sensitive information.

Description

ManageEngine ServiceDesk Plus 8.0, and possibly prior versions, contains a directory traversal vulnerability in the FileDownload.jsp page caused by an input validation error when handling requests. Additionally, ServiceDesk Plus 8.0 fails to verify that requests to the FileDownload.jsp page originate from an authenticated user. An unauthenticated attacker can exploit these vulnerabilities via directory traversal specifiers sent in a specially crafted request to the FileDownload.jsp page.


Impact

A remote unauthenticated attacker could obtain sensitive information.


Solution

Apply an Update

ManageEngine recommends users update to ManageEngine Service Desk Build 8012 or later.


Vendor Information

Vendor| Status| Date Notified| Date Updated
---|---|---|---
Zoho| | 16 May 2011| 22 Jun 2011
If you are a vendor and your product is affected, let us know.

CVSS Metrics

Group | Score | Vector
---|---|---
Base | N/A | N/A
Temporal | N/A | N/A
Environmental | N/A | N/A

References

  • <http://www.manageengine.com/products/service-desk/service-packs.html>

Credit

Thanks to Keith Lee Yong Ming for reporting this vulnerability.

This document was written by Jared Allar.

Other Information

  • CVE IDs: Unknown
  • Date Public: 21 Jun 2011
  • Date First Published: 27 Jun 2011
  • Date Last Updated: 27 Jun 2011
  • Severity Metric: 2.43
  • Document Revision: 10