Cisco Catalyst switches allow access to "enable mode" without password

2003-05-05T00:00:00
ID VU:443257
Type cert
Reporter CERT
Modified 2004-02-23T00:00:00

Description

Overview

Cisco Catalyst OS 7.5(1) contains a vulnerability that allows anyone who can obtain command line access to gain "enable" mode access without knowledge of the "enable" password.

Description

Cisco Catalyst OS is an operating system for Cisco's line of Catalyst switches. Version 7.5(1) of Catalyst OS contains a vulnerability that could allow an intruder with command line access to gain access to "enable" mode. Enable mode provides access to administrative functions of the switch. The problem affects "all users of Cisco Catalyst 4000, 6000, and 6500 with the Catalyst OS software version 7.5(1) only," according to the Cisco Advisory. This vulnerability does not affect Catalyst hardware running any version of IOS. Furthermore, this vulnerability is distinct from a similar vulnerability described in a previous Cisco advisory.


Impact

An intruder who can gain access to the command line can gain access to functions protected by "enable" mode without knowledge of the "enable" password.


Solution

Apply a patch as described in the Cisco Advisory.


Systems Affected

Vendor| Status| Date Notified| Date Updated
---|---|---|---
Cisco Systems Inc.| | 23 Apr 2003| 05 May 2003
If you are a vendor and your product is affected, let us know.

CVSS Metrics

Group | Score | Vector
---|---|---
Base | N/A | N/A
Temporal | N/A | N/A
Environmental | N/A | N/A

References

  • <http://www.cisco.com/warp/public/707/cisco-sa-20030424-catos.shtml>
  • <http://www.cisco.com/warp/public/707/catos-enable-bypass-pub.shtml#details>

Credit

Thanks to Don Strickler of San Francisco State University for reporting this vulnerability to us. Cisco has credited Marco P. Rodrigues for reporting the vulnerability.

This document was written by Shawn V Hernan.

Other Information

  • CVE IDs: Unknown
  • Date Public: 24 Apr 2003
  • Date First Published: 05 May 2003
  • Date Last Updated: 23 Feb 2004
  • Severity Metric: 17.81
  • Document Revision: 5