Wyse ThinOS LPD service buffer overflow vulnerability

ID VU:320233
Type cert
Reporter CERT
Modified 2010-08-16T00:00:00



Wyse ThinOS HF 4.4.079i has a buffer overflow vulnerability in the LPD service (515/tcp).


The LPD service (515/tcp) on Wyse ThinOS HF 4.4.079i crashes when a long buffer is sent to it. This condition may exist in all versions before Wyse ThinOS 6.5.


An attacker can cause the device to crash and may be able to execute arbitrary code.


The vendor recommends users upgrade to Wyse ThinOS 6.5 or newer.

Restrict Access

Enable firewall rules to restrict access for port 515/tcp to only trusted sources.

Vendor Information

Vendor| Status| Date Notified| Date Updated
Wyse| | 19 Nov 2009| 16 Aug 2010
If you are a vendor and your product is affected, let us know.

CVSS Metrics

Group | Score | Vector
Base | N/A | N/A
Temporal | N/A | N/A
Environmental | N/A | N/A


  • None


Thanks to Kevin Finisterres for reporting this vulnerability.

This document was written by Jared Allar.

Other Information

  • CVE IDs: Unknown
  • Date Public: 16 Aug 2010
  • Date First Published: 16 Aug 2010
  • Date Last Updated: 16 Aug 2010
  • Document Revision: 23