nspr, nss security update

2015-11-04T11:34:51
ID CESA-2015:1980
Type centos
Reporter CentOS Project
Modified 2015-11-04T11:36:19

Description

CentOS Errata and Security Advisory CESA-2015:1980

Network Security Services (NSS) is a set of libraries designed to support cross-platform development of security-enabled client and server applications. Netscape Portable Runtime (NSPR) provides platform independence for non-GUI operating system facilities.

A use-after-poison flaw and a heap-based buffer overflow flaw were found in the way NSS parsed certain ASN.1 structures. An attacker could use these flaws to cause NSS to crash or execute arbitrary code with the permissions of the user running an application compiled against the NSS library. (CVE-2015-7181, CVE-2015-7182)

A heap-based buffer overflow was found in NSPR. An attacker could use this flaw to cause NSPR to crash or execute arbitrary code with the permissions of the user running an application compiled against the NSPR library. (CVE-2015-7183)

Red Hat would like to thank the Mozilla project for reporting these issues. Upstream acknowledges Tyson Smith, David Keeler and Ryan Sleevi as the original reporter.

All nss and nspr users are advised to upgrade to these updated packages, which contain backported patches to correct these issues.

Merged security bulletin from advisories: http://lists.centos.org/pipermail/centos-announce/2015-November/033510.html http://lists.centos.org/pipermail/centos-announce/2015-November/033511.html

Affected packages: nspr nspr-devel nss nss-devel nss-pkcs11-devel nss-tools

Upstream details at: https://rhn.redhat.com/errata/RHSA-2015-1980.html