tomcat security update

2015-05-13T00:54:05
ID CESA-2015:0983
Type centos
Reporter CentOS Project
Modified 2015-05-13T00:54:05

Description

CentOS Errata and Security Advisory CESA-2015:0983

Apache Tomcat is a servlet container for the Java Servlet and JavaServer Pages (JSP) technologies.

It was discovered that the ChunkedInputFilter in Tomcat did not fail subsequent attempts to read input after malformed chunked encoding was detected. A remote attacker could possibly use this flaw to make Tomcat process part of the request body as new request, or cause a denial of service. (CVE-2014-0227)

All Tomcat 7 users are advised to upgrade to these updated packages, which contain a backported patch to correct this issue. After installing this update, the tomcat service will be restarted automatically.

Merged security bulletin from advisories: http://lists.centos.org/pipermail/centos-announce/2015-May/033166.html

Affected packages: tomcat tomcat-admin-webapps tomcat-docs-webapp tomcat-el-2.2-api tomcat-javadoc tomcat-jsp-2.2-api tomcat-jsvc tomcat-lib tomcat-servlet-3.0-api tomcat-webapps

Upstream details at: https://rhn.redhat.com/errata/RHSA-2015-0983.html