gnutls security update

2013-05-30T18:50:13
ID CESA-2013:0883
Type centos
Reporter CentOS Project
Modified 2013-05-30T20:28:37

Description

CentOS Errata and Security Advisory CESA-2013:0883

The GnuTLS library provides support for cryptographic algorithms and for protocols such as Transport Layer Security (TLS).

It was discovered that the fix for the CVE-2013-1619 issue released via RHSA-2013:0588 introduced a regression in the way GnuTLS decrypted TLS/SSL encrypted records when CBC-mode cipher suites were used. A remote attacker could possibly use this flaw to crash a server or client application that uses GnuTLS. (CVE-2013-2116)

Users of GnuTLS are advised to upgrade to these updated packages, which correct this issue. For the update to take effect, all applications linked to the GnuTLS library must be restarted.

Merged security bulletin from advisories: http://lists.centos.org/pipermail/centos-announce/2013-May/019766.html http://lists.centos.org/pipermail/centos-announce/2013-May/019767.html

Affected packages: gnutls gnutls-devel gnutls-guile gnutls-utils

Upstream details at: https://rhn.redhat.com/errata/RHSA-2013-0883.html