perl security update

2012-07-25T14:33:00
ID CESA-2012:1116
Type centos
Reporter CentOS Project
Modified 2012-07-25T15:12:37

Description

CentOS Errata and Security Advisory CESA-2012:1116

Perl DBI is a database access Application Programming Interface (API) for the Perl language. perl-DBD-Pg allows Perl applications to access PostgreSQL database servers.

Two format string flaws were found in perl-DBD-Pg. A specially-crafted database warning or error message from a server could cause an application using perl-DBD-Pg to crash or, potentially, execute arbitrary code with the privileges of the user running the application. (CVE-2012-1151)

All users of perl-DBD-Pg are advised to upgrade to this updated package, which contains a backported patch to fix these issues. Applications using perl-DBD-Pg must be restarted for the update to take effect.

Merged security bulletin from advisories: http://lists.centos.org/pipermail/centos-announce/2012-July/018764.html http://lists.centos.org/pipermail/centos-announce/2012-July/018765.html

Affected packages: perl-DBD-Pg

Upstream details at: https://rhn.redhat.com/errata/RHSA-2012-1116.html