libpng security update

2012-03-20T23:39:58
ID CESA-2012:0407
Type centos
Reporter CentOS Project
Modified 2012-03-21T02:53:51

Description

CentOS Errata and Security Advisory CESA-2012:0407

The libpng packages contain a library of functions for creating and manipulating PNG (Portable Network Graphics) image format files.

A heap-based buffer overflow flaw was found in the way libpng processed compressed chunks in PNG image files. An attacker could create a specially-crafted PNG image file that, when opened, could cause an application using libpng to crash or, possibly, execute arbitrary code with the privileges of the user running the application. (CVE-2011-3045)

Users of libpng should upgrade to these updated packages, which correct this issue. For Red Hat Enterprise Linux 5, they contain a backported patch. For Red Hat Enterprise Linux 6, they upgrade libpng to version 1.2.48. All running applications using libpng must be restarted for the update to take effect.

Merged security bulletin from advisories: http://lists.centos.org/pipermail/centos-announce/2012-March/030545.html http://lists.centos.org/pipermail/centos-announce/2012-March/030546.html

Affected packages: libpng libpng-devel libpng-static

Upstream details at: https://rhn.redhat.com/errata/RHSA-2012-0407.html