perl security update

2010-07-12T13:00:47
ID CESA-2010:0505
Type centos
Reporter CentOS Project
Modified 2010-07-21T15:26:02

Description

CentOS Errata and Security Advisory CESA-2010:0505

The Archive::Tar module provides a mechanism for Perl scripts to manipulate tar archive files.

Multiple directory traversal flaws were discovered in the Archive::Tar module. A specially-crafted tar file could cause a Perl script, using the Archive::Tar module to extract the archive, to overwrite an arbitrary file writable by the user running the script. (CVE-2007-4829)

This package upgrades the Archive::Tar module to version 1.39_01. Refer to the Archive::Tar module's changes file, linked to in the References, for a full list of changes.

Users of perl-Archive-Tar are advised to upgrade to this updated package, which corrects these issues. All applications using the Archive::Tar module must be restarted for this update to take effect.

Merged security bulletin from advisories: http://lists.centos.org/pipermail/centos-announce/2010-July/016749.html http://lists.centos.org/pipermail/centos-announce/2010-July/016750.html http://lists.centos.org/pipermail/centos-announce/2010-July/016813.html http://lists.centos.org/pipermail/centos-announce/2010-July/016814.html

Affected packages: perl-Archive-Tar

Upstream details at: https://rhn.redhat.com/errata/RHSA-2010-0505.html