pam_krb5 security update

2008-10-05T17:32:46
ID CESA-2008:0907
Type centos
Reporter CentOS Project
Modified 2008-10-05T17:32:46

Description

CentOS Errata and Security Advisory CESA-2008:0907

The pam_krb5 module allows Pluggable Authentication Modules (PAM) aware applications to use Kerberos to verify user identities by obtaining user credentials at log in time.

A flaw was found in the pam_krb5 "existing_ticket" configuration option. If a system is configured to use an existing credential cache via the "existing_ticket" option, it may be possible for a local user to gain elevated privileges by using a different, local user's credential cache. (CVE-2008-3825)

Red Hat would like to thank Stephane Bertin for responsibly disclosing this issue.

Users of pam_krb5 should upgrade to this updated package, which contains a backported patch to resolve this issue.

Merged security bulletin from advisories: http://lists.centos.org/pipermail/centos-announce/2008-October/027343.html http://lists.centos.org/pipermail/centos-announce/2008-October/027344.html

Affected packages: pam_krb5

Upstream details at: https://rhn.redhat.com/errata/RHSA-2008-0907.html