pcre security update

2007-11-05T18:41:23
ID CESA-2007:0968
Type centos
Reporter CentOS Project
Modified 2007-11-08T12:04:07

Description

CentOS Errata and Security Advisory CESA-2007:0968

PCRE is a Perl-compatible regular expression library.

Multiple flaws were found in the way pcre handles certain malformed regular expressions. If an application linked against pcre, such as Konqueror, parses a malicious regular expression, it may be possible to run arbitrary code as the user running the application. (CVE-2007-1660)

Users of pcre are advised to upgrade to these updated packages, which contain backported patches to correct these issues.

Red Hat would like to thank Tavis Ormandy and Will Drewry for properly disclosing these issues.

Merged security bulletin from advisories: http://lists.centos.org/pipermail/centos-announce/2007-November/014364.html http://lists.centos.org/pipermail/centos-announce/2007-November/014365.html http://lists.centos.org/pipermail/centos-announce/2007-November/014389.html http://lists.centos.org/pipermail/centos-announce/2007-November/014390.html

Affected packages: pcre pcre-devel

Upstream details at: https://rhn.redhat.com/errata/RHSA-2007-0968.html