dia security update

2006-05-04T01:13:24
ID CESA-2006:0280-01
Type centos
Reporter CentOS Project
Modified 2006-05-04T01:13:24

Description

CentOS Errata and Security Advisory CESA-2006:0280-01

The Dia drawing program is designed to draw various types of diagrams.

infamous41md discovered three buffer overflow bugs in Dia's xfig file format importer. If an attacker is able to trick a Dia user into opening a carefully crafted xfig file, it may be possible to execute arbitrary code as the user running Dia. (CVE-2006-1550)

Users of Dia should update to these erratum packages, which contain backported patches and are not vulnerable to these issues.

Merged security bulletin from advisories: http://lists.centos.org/pipermail/centos-announce/2006-May/024919.html

Affected packages: dia

Upstream details at: https://rhn.redhat.com/errata/rh21as-errata.html