libc security update

2005-12-06T17:48:48
ID CESA-2005:848
Type centos
Reporter CentOS Project
Modified 2005-12-06T19:20:04

Description

CentOS Errata and Security Advisory CESA-2005:848

C-client is a common API for accessing mailboxes.

A buffer overflow flaw was discovered in the way C-client parses user supplied mailboxes. If an authenticated user requests a specially crafted mailbox name, it may be possible to execute arbitrary code on a server that uses C-client to access mailboxes. The Common Vulnerabilities and Exposures project has assigned the name CVE-2005-2933 to this issue.

All users of libc-client should upgrade to these updated packages, which contain a backported patch that resolves this issue.

Merged security bulletin from advisories: http://lists.centos.org/pipermail/centos-announce/2005-December/012455.html http://lists.centos.org/pipermail/centos-announce/2005-December/012456.html http://lists.centos.org/pipermail/centos-announce/2005-December/012461.html http://lists.centos.org/pipermail/centos-announce/2005-December/012462.html http://lists.centos.org/pipermail/centos-announce/2005-December/012466.html

Affected packages: libc-client libc-client-devel

Upstream details at: https://rhn.redhat.com/errata/RHSA-2005-848.html