gnutls security update

2005-06-01T17:23:30
ID CESA-2005:430
Type centos
Reporter CentOS Project
Modified 2005-06-02T21:42:22

Description

CentOS Errata and Security Advisory CESA-2005:430

The GnuTLS library implements Secure Sockets Layer (SSL v3) and Transport Layer Security (TLS v1) protocols.

A denial of service bug was found in the GnuTLS library versions prior to 1.0.25. A remote attacker could perform a carefully crafted TLS handshake against a service that uses the GnuTLS library causing the service to crash. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2005-1431 to this issue.

All users of GnuTLS are advised to upgrade to these updated packages and to restart any services which use GnuTLS.

Merged security bulletin from advisories: http://lists.centos.org/pipermail/centos-announce/2005-June/023807.html http://lists.centos.org/pipermail/centos-announce/2005-June/023808.html http://lists.centos.org/pipermail/centos-announce/2005-June/023821.html

Affected packages: gnutls gnutls-devel

Upstream details at: https://rhn.redhat.com/errata/RHSA-2005-430.html