Lucene search

K
atlassianSecurity-metrics-botJSWSERVER-25409
HistoryNov 12, 2023 - 1:45 p.m.

Deserialization com.fasterxml.jackson.core:jackson-databind in Jira Software Data Center and Server

2023-11-1213:45:26
security-metrics-bot
jira.atlassian.com
30
jira software
data center
server
deserialization
vulnerability
third-party dependency
cvss score
cvss vector
atlassian
upgrade
release notes
national vulnerability database
fasterxml jackson-databind

CVSS3

7.5

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

AI Score

6.6

Confidence

High

EPSS

0.003

Percentile

66.3%

This High severity Third-Party Dependency vulnerability was introduced in versions 8.20.0, 9.4.0, 9.5.0, 9.6.0, 9.7.0, 9.8.0, 9.9.0, 9.10.0, and 9.11.0 of Jira Software Data Center and Server.

This Third-Party Dependency vulnerability, with a CVSS Score of 7.5 and a CVSS Vector of CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H allows an unauthenticated attacker to expose assets in your environment susceptible to exploitation which has no impact to confidentiality, no impact to integrity, high impact to availability, and requires no user interaction. 

Atlassian recommends that Jira Software Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions:
	
	* Jira Software Data Center and Server 9.11: Upgrade to a release greater than or equal to 9.11.3
	
	

See the release notes. You can download the latest version of Jira Software Data Center and Server from the download center.

The National Vulnerability Database provides the following description for this vulnerability: In FasterXML jackson-databind before 2.13.4, resource exhaustion can occur because of a lack of a check in BeanDeserializer._deserializeFromArray to prevent use of deeply nested arrays. An application is vulnerable only with certain customized choices for deserialization.

Affected configurations

Vulners
Node
atlassianjira_software_data_centerRange8.20.0
OR
atlassianjira_software_data_centerRange9.4.0
OR
atlassianjira_software_data_centerRange9.5.0
OR
atlassianjira_software_data_centerRange9.6.0
OR
atlassianjira_software_data_centerRange9.7.0
OR
atlassianjira_software_data_centerRange9.8.0
OR
atlassianjira_software_data_centerRange9.9.0
OR
atlassianjira_software_data_centerRange9.10.0
OR
atlassianjira_software_data_centerRange9.11.0
OR
atlassianjira_software_data_centerRange9.11.1
OR
atlassianjira_software_data_centerRange9.11.2
OR
atlassianjira_software_data_centerRange<9.12.0
OR
atlassianjira_software_data_centerRange<9.11.3
OR
atlassianjira_software_data_centerRange<9.4.14

CVSS3

7.5

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

AI Score

6.6

Confidence

High

EPSS

0.003

Percentile

66.3%