Lucene search

K
atlassianSecurity-metrics-botCWD-6259
HistoryApr 09, 2024 - 1:53 a.m.

Information Disclosure org.eclipse.jetty:jetty-util Dependency in Crowd Data Center and Server

2024-04-0901:53:43
security-metrics-bot
jira.atlassian.com
6
org.eclipse.jetty:jetty-util
crowd data center and server
vulnerability
unauthenticated attacker
atlassian
upgrade

5 Medium

CVSS2

Attack Vector

NETWORK

Attack Complexity

LOW

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

NONE

Availability Impact

NONE

AV:N/AC:L/Au:N/C:P/I:N/A:N

7.5 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

NONE

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

7.2 High

AI Score

Confidence

Low

0.003 Low

EPSS

Percentile

69.6%

This High severity org.eclipse.jetty:jetty-util Dependency vulnerability was introduced in versions 5.0.0, 5.1.0, and 5.2.0 of Crowd Data Center and Server.

This org.eclipse.jetty:jetty-util Dependency vulnerability, with a CVSS Score of 7.5 and a CVSS Vector of CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N allows an unauthenticated attacker to expose assets in your environment susceptible to exploitation which has high impact to confidentiality, no impact to integrity, no impact to availability, and requires no user interaction.

Atlassian recommends that Crowd Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions:

||Affected versions||Fixed versions||
|5.2.0 to 5.2.3|5.2.4|
|5.1.0 to 5.1.8|5.1.9 or 5.2.4 recommended|
|5.0 to 5.0.10|5.1.9 or 5.2.4 recommended |
|Any earlier versions|5.1.9 or 5.2.4 recommended |

See the release notes ([https://confluence.atlassian.com/crowd/crowd-release-notes-199094.html]). You can download the latest version of Crowd Data Center and Server from the download center ([https://www.atlassian.com/software/crowd/download-archive]).

The National Vulnerability Database provides the following description for this vulnerability: Jetty through 9.4.x is prone to a timing channel in util/security/Password.java, which makes it easier for remote attackers to obtain access by observing elapsed times before rejection of incorrect passwords.

Affected configurations

Vulners
Node
atlassiancrowdRange5.0.0
OR
atlassiancrowdRange5.0.1
OR
atlassiancrowdRange5.1.0
OR
atlassiancrowdRange5.0.2
OR
atlassiancrowdRange5.0.3
OR
atlassiancrowdRange5.2.0
OR
atlassiancrowdRange5.0.4
OR
atlassiancrowdRange5.1.1
OR
atlassiancrowdRange5.1.2
OR
atlassiancrowdRange5.0.5
OR
atlassiancrowdRange5.0.6
OR
atlassiancrowdRange5.1.3
OR
atlassiancrowdRange5.1.4
OR
atlassiancrowdRange5.0.7
OR
atlassiancrowdRange5.1.5
OR
atlassiancrowdRange5.1.6
OR
atlassiancrowdRange5.0.8
OR
atlassiancrowdRange5.2.1
OR
atlassiancrowdRange5.2.2
OR
atlassiancrowdRange5.1.7
OR
atlassiancrowdRange5.0.9
OR
atlassiancrowdRange5.2.3
OR
atlassiancrowdRange5.1.8
OR
atlassiancrowdRange5.0.10
OR
atlassiancrowdRange<5.1.9
OR
atlassiancrowdRange<5.2.4

5 Medium

CVSS2

Attack Vector

NETWORK

Attack Complexity

LOW

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

NONE

Availability Impact

NONE

AV:N/AC:L/Au:N/C:P/I:N/A:N

7.5 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

NONE

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

7.2 High

AI Score

Confidence

Low

0.003 Low

EPSS

Percentile

69.6%