XSS vulnerability in FishEye/Crucible dashboard - review activity

2011-04-21T03:15:51
ID ATLASSIAN:FE-3031
Type atlassian
Reporter alui
Modified 2015-09-22T08:57:40

Description

We have identified and fixed a cross-site scripting (XSS) vulnerability in the FishEye/Crucible dashboard - review activity..

Affected versions are FishEye/Crucible 2.2.8 to 2.5.2 inclusive.

XSS vulnerabilities potentially allow an attacker to embed their own JavaScript into a FishEye/Crucible page. You can read more about XSS attacks at various places on the web, including these:

  • cgisecurity.com: http://www.cgisecurity.com/articles/xss-faq.shtml
  • The Web Application Security Consortium: http://projects.webappsec.org/Cross-Site+Scripting

This issue is reported in our security advisory on these pages:

  • https://confluence.atlassian.com/x/_QbSEQ
  • https://confluence.atlassian.com/x/hAjSEQ