ClassLoader manipulation vulnerability

2014-05-12T05:43:23
ID ATLASSIAN:CWD-3904
Type atlassian
Reporter vosipov
Modified 2016-09-13T08:53:54

Description

We have fixed a vulnerability in our fork of Apache Struts. Attackers can use this vulnerability to execute Java code of their choice on systems that use these frameworks. The attacker needs to be able to access the Crowd web interface. In cases when anonymous access is enabled, a valid user account is not required to exploit this vulnerability.

We have discovered this vulnerability during our review of the recent Struts security advisories. This vulnerability is specific to Crowd.

The vulnerability affects all supported version of Crowd. For more information see the full [advisory|https://confluence.atlassian.com/display/CROWD/Crowd+Security+Advisory+2014-05-21].