OGNL Double Evaluation Vulnerability

Type atlassian
Reporter dblack
Modified 2016-12-01T01:02:05


We have discovered and fixed a vulnerability in our fork of one of Apache Struts libraries. Attackers can use this vulnerability to execute Java code of their choice on systems that use these frameworks. The attacker needs to be able to access the Bamboo web interface.

All versions of Bamboo up to and including 5.7 are affected by this vulnerability.

The vulnerability has been fixed in recent releases 5.7.1 and 5.7.2.

For additional details see the full advisory.