Lucene search

K
amazonAmazonALAS2-2023-2308
HistoryOct 12, 2023 - 3:09 p.m.

Medium: ghostscript

2023-10-1215:09:00
alas.aws.amazon.com
17
ghostscript
buffer overflow
remote attackers
denial of service
crafted pdf
cve-2020-16294
cve-2020-21710

5.7 Medium

AI Score

Confidence

High

0.003 Low

EPSS

Percentile

68.8%

Issue Overview:

A buffer overflow vulnerability in epsc_print_page() in devices/gdevepsc.c of Artifex Software GhostScript v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51. (CVE-2020-16294)

A divide by zero issue discovered in eps_print_page in gdevepsn.c in Artifex Software GhostScript 9.50 allows remote attackers to cause a denial of service via opening of crafted PDF file. (CVE-2020-21710)

Affected Packages:

ghostscript

Note:

This advisory is applicable to Amazon Linux 2 (AL2) Core repository. Visit this FAQ section for the difference between AL2 Core and AL2 Extras advisories.

Issue Correction:
Run yum update ghostscript to update your system.

New Packages:

aarch64:  
    ghostscript-9.25-5.amzn2.0.7.aarch64  
    libgs-9.25-5.amzn2.0.7.aarch64  
    libgs-devel-9.25-5.amzn2.0.7.aarch64  
    ghostscript-gtk-9.25-5.amzn2.0.7.aarch64  
    ghostscript-cups-9.25-5.amzn2.0.7.aarch64  
    ghostscript-debuginfo-9.25-5.amzn2.0.7.aarch64  
  
i686:  
    ghostscript-9.25-5.amzn2.0.7.i686  
    libgs-9.25-5.amzn2.0.7.i686  
    libgs-devel-9.25-5.amzn2.0.7.i686  
    ghostscript-gtk-9.25-5.amzn2.0.7.i686  
    ghostscript-cups-9.25-5.amzn2.0.7.i686  
    ghostscript-debuginfo-9.25-5.amzn2.0.7.i686  
  
noarch:  
    ghostscript-doc-9.25-5.amzn2.0.7.noarch  
  
src:  
    ghostscript-9.25-5.amzn2.0.7.src  
  
x86_64:  
    ghostscript-9.25-5.amzn2.0.7.x86_64  
    libgs-9.25-5.amzn2.0.7.x86_64  
    libgs-devel-9.25-5.amzn2.0.7.x86_64  
    ghostscript-gtk-9.25-5.amzn2.0.7.x86_64  
    ghostscript-cups-9.25-5.amzn2.0.7.x86_64  
    ghostscript-debuginfo-9.25-5.amzn2.0.7.x86_64  

Additional References

Red Hat: CVE-2020-16294, CVE-2020-21710

Mitre: CVE-2020-16294, CVE-2020-21710