Lucene search

K
amazonAmazonALAS2-2022-1824
HistoryJul 19, 2022 - 1:19 a.m.

Important: java-17-amazon-corretto

2022-07-1901:19:00
alas.aws.amazon.com
112

7.5 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

HIGH

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

7.5 High

AI Score

Confidence

High

5 Medium

CVSS2

Access Vector

NETWORK

Access Complexity

LOW

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

NONE

Availability Impact

NONE

AV:N/AC:L/Au:N/C:P/I:N/A:N

0.002 Low

EPSS

Percentile

52.6%

Issue Overview:

Generated code produced by C1 may leak a package-private class to a class from a different package. (CVE-2022-21540)

MethodHandle.invokeBasic() method can be accessed on byte code level from an arbitrary class. (CVE-2022-21541)

computeNextExponential sometimes returns negative numbers contrary to the documentation. (CVE-2022-21549)

The Xalan Java XSLT library has an integer truncation issue when processing malicious stylesheets. This can be used to corrupt Java class files generated by the internal XSLTC compiler and execute arbitrary Java bytecode. (CVE-2022-34169)

Affected Packages:

java-17-amazon-corretto

Note:

This advisory is applicable to Amazon Linux 2 (AL2) Core repository. Visit this FAQ section for the difference between AL2 Core and AL2 Extras advisories.

Issue Correction:
Run yum update java-17-amazon-corretto to update your system.

New Packages:

aarch64:  
    java-17-amazon-corretto-17.0.4+8-1.amzn2.1.aarch64  
    java-17-amazon-corretto-devel-17.0.4+8-1.amzn2.1.aarch64  
    java-17-amazon-corretto-headless-17.0.4+8-1.amzn2.1.aarch64  
    java-17-amazon-corretto-javadoc-17.0.4+8-1.amzn2.1.aarch64  
    java-17-amazon-corretto-jmods-17.0.4+8-1.amzn2.1.aarch64  
  
src:  
    java-17-amazon-corretto-17.0.4+8-1.amzn2.1.src  
  
x86_64:  
    java-17-amazon-corretto-17.0.4+8-1.amzn2.1.x86_64  
    java-17-amazon-corretto-devel-17.0.4+8-1.amzn2.1.x86_64  
    java-17-amazon-corretto-headless-17.0.4+8-1.amzn2.1.x86_64  
    java-17-amazon-corretto-javadoc-17.0.4+8-1.amzn2.1.x86_64  
    java-17-amazon-corretto-jmods-17.0.4+8-1.amzn2.1.x86_64  

Additional References

Red Hat: CVE-2022-21540, CVE-2022-21541, CVE-2022-21549, CVE-2022-34169

Mitre: CVE-2022-21540, CVE-2022-21541, CVE-2022-21549, CVE-2022-34169

7.5 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

HIGH

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

7.5 High

AI Score

Confidence

High

5 Medium

CVSS2

Access Vector

NETWORK

Access Complexity

LOW

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

NONE

Availability Impact

NONE

AV:N/AC:L/Au:N/C:P/I:N/A:N

0.002 Low

EPSS

Percentile

52.6%