Medium: openssl

2021-02-19T01:21:00
ID ALAS2-2021-1608
Type amazon
Reporter Amazon
Modified 2021-02-19T01:21:00

Description

Issue Overview:

OpenSSL 1.0.2 supports SSLv2. If a client attempts to negotiate SSLv2 with a server that is configured to support both SSLv2 and more recent SSL and TLS versions then a check is made for a version rollback attack when unpadding an RSA signature. Clients that support SSL or TLS versions greater than SSLv2 are supposed to use a special form of padding. A server that supports greater than SSLv2 is supposed to reject connection attempts from a client where this special form of padding is present, because this indicates that a version rollback has occurred (i.e. both client and server support greater than SSLv2, and yet this is the version that is being requested). The implementation of this padding check inverted the logic so that the connection attempt is accepted if the padding is present, and rejected if it is absent. This means that such as server will accept a connection if a version rollback attack has occurred. Further the server will erroneously reject a connection if a normal SSLv2 connection attempt is made. Only OpenSSL 1.0.2 servers from version 1.0.2s to 1.0.2x are affected by this issue. In order to be vulnerable a 1.0.2 server must: 1) have configured SSLv2 support at compile time (this is off by default), 2) have configured SSLv2 support at runtime (this is off by default), 3) have configured SSLv2 ciphersuites (these are not in the default ciphersuite list) OpenSSL 1.1.1 does not have SSLv2 support and therefore is not vulnerable to this issue. The underlying error is in the implementation of the RSA_padding_check_SSLv23() function. This also affects the RSA_SSLV23_PADDING padding mode used by various other functions. Although 1.1.1 does not support SSLv2 the RSA_padding_check_SSLv23() function still exists, as does the RSA_SSLV23_PADDING padding mode. Applications that directly call that function or use that padding mode will encounter this issue. However since there is no support for the SSLv2 protocol in 1.1.1 this is considered a bug and not a security issue in that version. OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.0.2y (Affected 1.0.2s-1.0.2x). (CVE-2021-23839 __)

Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x). (CVE-2021-23840 __)

The OpenSSL public API function X509_issuer_and_serial_hash() attempts to create a unique hash value based on the issuer and serial number data contained within an X509 certificate. However it fails to correctly handle any errors that may occur while parsing the issuer field (which might occur if the issuer field is maliciously constructed). This may subsequently result in a NULL pointer deref and a crash leading to a potential denial of service attack. The function X509_issuer_and_serial_hash() is never directly called by OpenSSL itself so applications are only vulnerable if they use this function directly and they use it on certificates that may have been obtained from untrusted sources. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x). (CVE-2021-23841 __)

Affected Packages:

openssl

Issue Correction:
Run yum update openssl to update your system.

New Packages:

aarch64:  
    openssl-1.0.2k-19.amzn2.0.6.aarch64  
    openssl-libs-1.0.2k-19.amzn2.0.6.aarch64  
    openssl-devel-1.0.2k-19.amzn2.0.6.aarch64  
    openssl-static-1.0.2k-19.amzn2.0.6.aarch64  
    openssl-perl-1.0.2k-19.amzn2.0.6.aarch64  
    openssl-debuginfo-1.0.2k-19.amzn2.0.6.aarch64

i686:  
    openssl-1.0.2k-19.amzn2.0.6.i686  
    openssl-libs-1.0.2k-19.amzn2.0.6.i686  
    openssl-devel-1.0.2k-19.amzn2.0.6.i686  
    openssl-static-1.0.2k-19.amzn2.0.6.i686  
    openssl-perl-1.0.2k-19.amzn2.0.6.i686  
    openssl-debuginfo-1.0.2k-19.amzn2.0.6.i686

src:  
    openssl-1.0.2k-19.amzn2.0.6.src

x86_64:  
    openssl-1.0.2k-19.amzn2.0.6.x86_64  
    openssl-libs-1.0.2k-19.amzn2.0.6.x86_64  
    openssl-devel-1.0.2k-19.amzn2.0.6.x86_64  
    openssl-static-1.0.2k-19.amzn2.0.6.x86_64  
    openssl-perl-1.0.2k-19.amzn2.0.6.x86_64  
    openssl-debuginfo-1.0.2k-19.amzn2.0.6.x86_64