logo
DATABASE RESOURCES PRICING ABOUT US

Medium: ipa

Description

**Issue Overview:** jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when a cross-domain Ajax request is performed without the dataType option, causing text/javascript responses to be executed. (CVE-2015-9251) In Bootstrap 3.x before 3.4.0 and 4.x-beta before 4.0.0-beta.2, XSS is possible in the data-target attribute, a different vulnerability than CVE-2018-14041. (CVE-2016-10735) In Bootstrap before 4.1.2, XSS is possible in the collapse data-parent attribute. (CVE-2018-14040) In Bootstrap before 4.1.2, XSS is possible in the data-container property of tooltip. (CVE-2018-14042) In Bootstrap before 3.4.0, XSS is possible in the tooltip data-viewport attribute. (CVE-2018-20676) In Bootstrap before 3.4.0, XSS is possible in the affix configuration target property. (CVE-2018-20677) A Prototype Pollution vulnerability was found in jquery. Untrusted JSON passed to the `extend` function could lead to modifying objects up the prototype chain, including the global Object. A crafted JSON object passed to a vulnerable method could lead to denial of service or data injection, with various consequences. (CVE-2019-11358) A cross-site scripting vulnerability was discovered in bootstrap. If an attacker could control the data given to tooltip or popover, they could inject HTML or Javascript into the rendered page when tooltip or popover events fired. (CVE-2019-8331) A Cross-site scripting (XSS) vulnerability exists in JQuery. This flaw allows an attacker with the ability to supply input to the 'HTML' function to inject Javascript into the page where that input is rendered, and have it delivered by the browser. (CVE-2020-11022) A flaw was found in IPA. When sending a very long password (>= 1,000,000 characters) to the server, the password hashing process could exhaust memory and CPU leading to a denial of service and the website becoming unresponsive. The highest threat from this vulnerability is to system availability. (CVE-2020-1722) **Affected Packages:** ipa **Issue Correction:** Run _yum update ipa_ to update your system. **New Packages:** aarch64:     ipa-server-4.6.8-5.amzn2.aarch64     ipa-server-trust-ad-4.6.8-5.amzn2.aarch64     ipa-client-4.6.8-5.amzn2.aarch64     ipa-debuginfo-4.6.8-5.amzn2.aarch64 i686:     ipa-server-4.6.8-5.amzn2.i686     ipa-server-trust-ad-4.6.8-5.amzn2.i686     ipa-client-4.6.8-5.amzn2.i686     ipa-debuginfo-4.6.8-5.amzn2.i686 noarch:     python2-ipaserver-4.6.8-5.amzn2.noarch     ipa-server-common-4.6.8-5.amzn2.noarch     ipa-server-dns-4.6.8-5.amzn2.noarch     python2-ipaclient-4.6.8-5.amzn2.noarch     ipa-client-common-4.6.8-5.amzn2.noarch     ipa-python-compat-4.6.8-5.amzn2.noarch     python2-ipalib-4.6.8-5.amzn2.noarch     ipa-common-4.6.8-5.amzn2.noarch src:     ipa-4.6.8-5.amzn2.src x86_64:     ipa-server-4.6.8-5.amzn2.x86_64     ipa-server-trust-ad-4.6.8-5.amzn2.x86_64     ipa-client-4.6.8-5.amzn2.x86_64     ipa-debuginfo-4.6.8-5.amzn2.x86_64


Affected Package


OS OS Version Package Name Package Version
Amazon Linux 2 ipa-server 4.6.8-5.amzn2
Amazon Linux 2 ipa-server-trust-ad 4.6.8-5.amzn2
Amazon Linux 2 ipa-client 4.6.8-5.amzn2
Amazon Linux 2 ipa-debuginfo 4.6.8-5.amzn2
Amazon Linux 2 ipa-server 4.6.8-5.amzn2
Amazon Linux 2 ipa-server-trust-ad 4.6.8-5.amzn2
Amazon Linux 2 ipa-client 4.6.8-5.amzn2
Amazon Linux 2 ipa-debuginfo 4.6.8-5.amzn2
Amazon Linux 2 python2-ipaserver 4.6.8-5.amzn2
Amazon Linux 2 ipa-server-common 4.6.8-5.amzn2
Amazon Linux 2 ipa-server-dns 4.6.8-5.amzn2
Amazon Linux 2 python2-ipaclient 4.6.8-5.amzn2
Amazon Linux 2 ipa-client-common 4.6.8-5.amzn2
Amazon Linux 2 ipa-python-compat 4.6.8-5.amzn2
Amazon Linux 2 python2-ipalib 4.6.8-5.amzn2
Amazon Linux 2 ipa-common 4.6.8-5.amzn2
Amazon Linux 2 ipa 4.6.8-5.amzn2
Amazon Linux 2 ipa-server 4.6.8-5.amzn2
Amazon Linux 2 ipa-server-trust-ad 4.6.8-5.amzn2
Amazon Linux 2 ipa-client 4.6.8-5.amzn2
Amazon Linux 2 ipa-debuginfo 4.6.8-5.amzn2

Related